syjq.net
当前位置:首页 >> quArtz 1.5.2.jAr >>

quArtz 1.5.2.jAr

quartz-all-1.6.0.jar spring-context-support.jar commons-collections-3.2.jar 一定要是 3.x 的版本 默认ssh是2.X的版本

根据更新log Changes in version 3.1.1 (2012-02-16) * fixed QuartzJobBean and MethodInvokingJobDetailFactoryBean for compatibility with Quartz 2.0/2.1 3.1.1始加入2.02.1支持据我所知现支持应该集Quartz1.8.5版本吧

这个只有一个.jar ~~~~~~~~~~~~

commons-collections-3.2.jar commons-logging-1.1.1.jar log4j-1.2.16.jar spring.jar(spring的所有jar包)

你用的spring版本是多少啊?? MethodInvokingJobDetailFactoryBean这个类是spring包里提供的 看看你的spring包里有没有这个类

spring框架中的包

commons-collections-3.2.jar commons-logging-1.1.1.jar log4j-1.2.16.jar spring.jar(spring的所有jar包)

2.5版本之前所需的包: commons-logging.jar, log4j-1.2.15.jar, servlet-api.jar, spring.jar, spring-web.jar, spring-webmvc.jar 2.5版本之后所需的包: commons-logging.jar, log4j-1.2.15.jar, servlet-api.jar, spring.jar

可能你加加载了quartz jar包,你看下你工程里面是否有这个JAR包,有时候是集成在一起的.... 因为quartz可以配在spring里面,有时候你下载下来的spring库JAR里面有一个quartz jar包你没看到

根据更新log Changes in version 3.1.1 (2012-02-16) * fixed QuartzJobBean and MethodInvokingJobDetailFactoryBean for compatibility with Quartz 2.0/2.1 从3.1.1开始加入了对2.0,2.1的支持,但是据我所知现在支持还不好。应该还是集成Qua...

网站首页 | 网站地图
All rights reserved Powered by www.syjq.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com